Create identity-secure, just-in-time access to all your enterprise environments: cloud, on-premises, and OT.
Recently active
I’m wondering if anyone has found a way to use a Kubernetes Cluster Tunnel effectively within BeyondTrust PRA, as documented here: https://docs.beyondtrust.com/pra/docs/jump-shortcuts#create-a-kubernetes-cluster-tunnelPrimarily what I’m curious about is how to use the temporarily generated KubeConfig and actually authenticate to a cluster? The KubeConfig that is generated doesn’t appear to do credential injection from PRA, nor can I utilize Azure CLI to get credentials for my AKS cluster injected. It seems like it would be a very poor user experience to have to have locally stored cluster credentials which must be added to the generated KubeConfig every time a connection is made. In addition, this is completely divergent from the patterns of PRA and Remote RDP where a user doesn’t have access to privileged credentials at all (due to credential injection). I have searched through documentation and opened a support ticket without getting any real answers, so I thought I’d reach out to th
Hi team,I’ve deployed a Jump Client installer with the "Maximum Offline Minutes Before Deletion" parameter set to zero, specifically to prevent the clients from being removed due to offline status. However, I’m seeing three systems currently marked as "Pending Removal" in the console.These systems have been offline since deployment, and I haven’t manually marked them for deletion. Could this be related to appliance updates, license limits, or some backend policy?Is there a way to cancel the pending removal status without reinstalling the Jump Client?Thanks in advance for your support!
The following articles were published last week. New Knowledge Base Articles: KB0021556 - Missing command shell tab KB0021561 - How to enable virtual smart card logging KB0022292 - How to add or modify a tag and create or update nested sub-groups for Jump Items KB0022560 - All fields greyed out when creating a new remote jump shortcut or using the Jump to option KB0022855 - How to create a new vendor in PRA KB0022858 - Croatian (HRV) keyboard "@" symbol not working on Windows login screen for PRA KB0022870 - Access Console SQL Jump error: "Unable to find suitable datasource client" KB0022888 - After upgrade, RS and PRA triggering security warnings regarding Content-Security-Policy headers KB0022893 - Unable to remove other users from session as an Administrator KB0022897 - Does Vault support AWS secrets?
Hi, how are you?We're having trouble registering discovery for the AWS domain. Is there AWS support for Vault Discovery or only Microsoft? If so, what guidance or documentation is available, please provide.
Hi,Could anyone explain how the Advanced Web Access feature in BeyondTrust PRA actually works?Additionally, what are the practical and technical differences between using Advanced Web Access and a traditional WebJump item for accessing web consoles or administration portals?
I'm looking to see if I'm correct in how to read the Active Client licenses.When I look in our BTRS consol dasbhoard we see the amount of Client Agents purchased under: Total Active Jump Clients AllowedLet's say this amount is 20000 licenses.Now when I scroll down in this same page, I see a usage under: Remote Support Active Jump ClientLet's say this amount is 4500 licenses.When I navigate to the BeyondTrust Representative Consol I see at the bottom: 18000 Jump clients Total / 4500 online / 13500 offline.Would this mean I have only 2000 licenses left to use out of 20000, or do we have 15500 licenses left to use, ignoring how many installations we have, meaning for all we know, we can have 50000 Jump clients total installed, but we should never exceed 20000 online.
The following articles were published last week. New Knowledge Base Articles: KB0021581 - How to capture ACH logs for Remote Support and Privileged Remote Access KB0021589 - Restart options missing in Remote Support or Privileged Remote Access KB0022274 - Cannot jump to certain computers. Location for endpoints leverages a Jumpoint Proxy. Error - The operation timed out KB0022845 - Unable to connect to a Jump Item with "MFA required" Jump Policy applied. Error "authentication failure" KB0022846 - Unable to connect to MySQL database. Error "#42000: Unsupported plugin offered from server" KB0022848 - Can NTLMv2 be turned off for RS or PRA? KB0022853 - Is it possible for RS or PRA users to see credentials injected to a remote session from Password Safe? KB0022861 - Desktop Console keeps crashing KB0022868 - Loss of mouse control and black dot on remote sessions after upgrade to
I’ve noticed a couple annoying issues since updating PRA from 25.1.1 to 25.1.2. We only exclusively use Jump Clients to Windows Servers and Clients through the console, and here’s what I’ve noticed:During the connection process after logging into Windows, if you switch focus to a different tab/connection and then come back, the jump client will have connected, but you will not have mouse control. You can use keyboard control or use any of the quick commands from the Console, but in order to get mouse control back, you must fully disconnect and reconnect back into the jump client, ensuring you don’t switch focus to a different server. This one is pretty consistent and can be reproduced almost every time. This one is a little more random and doesn’t always happen, but I’ve noticed it happening often now since the PRA update. In order to launch applications in Windows, I have the habit and clicking the Windows Start key and immediately start typing the product/application I need to launch
The following articles were published last week. New Knowledge Base Articles: KB0021414 - Sign-in loops and shows an unexpected error occurred with SAML authentication due to UPN mismatch KB0022784 - Privileged Remote Access and Remote Support 25.2 operating system certification matrix KB0022822 - Newly deployed Jump Clients show disconnected KB0022824 - Unable to Jump to VNC Resource. "No security types supported." KB0022838 - How to extend the expiration date of vendor users KB0022844 - Why do some jump items continue to show an online status when the machine is switched off? KB0022859 - How does Network Tunnel Service work during PRA updates?
The following articles were published last week. New Knowledge Base Articles: KB0022808 - Jump Client Direct Download link does not work. Incorrectly prompts for Pathfinder authentication KB0022811 - How to run the session policy to simulator to check for permission issues KB0022815 - SAML IdP cloud groups showing as GUID's under Group Policies in Pathfinder KB0022820 - Vendor user cannot register recieves error: Email address from this domain is not allowed KB0022828 - What is the 'Verified Administrator' for RS or PRA? Can it be changed or updated?
Real-World Success Stories with BeyondTrust Remote Support Many of BeyondTrust’s current Remote Support customers sought a new remote support solution because of business challenges. They were on the hunt for a solution that unified their help desk use cases with key integrations and boosted productivity, all while addressing security concerns and adhering to compliance requirements. One payment and processing company saw an 80% increase in productivity after implementing our solution.This article will dive into why a few of our real-world customers decided on Remote Support as their IT software of choice, and will reveal the measurable gains they’ve made in productivity, security, and compliance. Real-World Success Stories with BeyondTrust Remote Support Many of BeyondTrust’s current Remote Support customers sought a new remote support solution because of business challenges. They were on the hunt for a solution that unified their help desk use cases with key integrations and boosted
In Remote Support and Privileged Remote Access, some binaries will undergo a name change. Client name changes for Windows took place in 25.1. In 25.2, files for Mac/Linux clients as well as Jumpoints for all operating systems will be changed. In addition, directory name changes will take place, changing from Bomgar, to BeyondTrust for new installations. Existing installations will not be impacted. No action is necessary for these changes to occur, but if you are currently whitelisting directories or binaries by name with your endpoint security, you may need to update your whitelist configuration to accommodate the name changes. Old Name New Name bomgar-scc sra-scc bomgar-pec sra-scc bomgar-rep sra-con bomgar-acc sra-con bomgar-jpt sra-jpt bomgar-sjt sra-sjt bomgar-sjp sra-sjp bomgar-rfb sra-rfb bomgar-rdp sra-rdp bomgar-rdt sra
Is there a way to make sure, that SAML sessions (used to logon to PRA) are deleted after disconnecting from PRA (Access Console / Web Console)?Thank you!
The following articles were published last week. New Knowledge Base Articles: KB0022108 - Privileged Remote Access and Remote Support 25.1 operating system certification matrix KB0022514 - Kubernetes cluster tunnel greyed out "No Protocol Tunnel Jumpoints Available" KB0022737 - Can web jumps be used for web apps that have Java popups? KB0022797 - Unable to delete Jump Items in the Representative Console or Access Console list KB0022802 - Error when adding new traffic node in existing setup "The authentication step failed"
The following articles were published last week. New Knowledge Base Articles: KB0021961 - How to create a Service Principal in an Entra ID domain services Account KB0022748 - Local users are unable to log in to the Representative Console. Error "418 Failed to decrypt" KB0022771 - PRA Registration links fail in Microsoft environments due to Safe Links rewriting
The following articles were published last week. New Knowledge Base Articles: KB0022238 - How does licensing work in Privileged Remote Access ? - License usage and how to add more licenses KB0022737 - Can web jumps be used for web apps that use Java popups? KB0022738 - Can session recordings be turned off per user?
Hi guys, i cannot find a button for “ Create Policy” , anything i can do?
Best Practices for Remote Support and Privileged Remote Access Here are a few best practices for delivering secure and efficient remote support. Following these guidelines can help improve performance, reduce risk, and maintain compliance. Review the supported version lifecycle at least once a year and keep up to date. Having older software, more than two years behind, may make it more complex to get to the latest version. In some cases, a new appliance will need to be created. Refer to How to upgrade or update version 20.1.x and lower. If self-hosted, stay up-to-date with current releases and activate the Apply Critical Updates Automatically option found in the /appliance interface. For instructions, refer to Automatic critical update options in /appliance. Consider using an external authentication security providers (for example, SAML) over local accounts, and be sure to delete accounts not in use. For more information, refer to PRA Security providers or RS Security providers.
Create more than one Integration with Service now ITSM tool, if a customer has different entities and has different ITSM tools like Servicenow and Fresh Desk.
The following articles were published last week. New Knowledge Base Articles: KB0022212 - Unable to copy and paste from the Web Console" to "Unable to copy and paste from the Web Console using Web Shell to SSH KB0022714 - Which ports are required for ad-hoc sessions in Remote Support? KB0022717 - What network traffic does an active Jump Client send and can this be configured or inspected? KB0022718 - Network tunnel stuck on "Setting up server endpoint" KB0022727 - Remote Support and Privileged Remote Access Atlas certificate requirements
We're extracting the team activity reports and add this to our BI reporting to monitor usage.On the event type we see several events and I'm looking to filter the ones to connect and disconnect from a session.I think the below are the ones that I'm looking for but not sure: Conference Member Added -> connecting to a workstation Conference Member Departed -> disconnecting from a workstation Am I correct in this assumption?
Can we connect to SQL DB with a different instance example sqlserver\abc. how can I use on the SQL Server Tunnel in the PRA to connect.
we are planning to move from PRA B-200 physical to VM. the article below doesn’t explain that how many concurrent jump sessions (RDP/Shell/WEB) a VM can handle in Active-Passive configuration. ( considering not jump client installed)Virtual Appliance installation
we have linux server in which XRDP is installed. from console I cannot RDP the linux but I can do RDP from a server (jumpoint host).what am I doing wrong here?
The following articles were published last week. New Knowledge Base Articles: KB0022081 - Approval emails for sessions have stopped working error - SMTP error [450] Service unavailable KB0022647 - How to download the SIEM Q radar plugin for Remote Support or Privileged Remote Access integration KB0022705 - Does a live update require downtime?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.